Announcement

Collapse
No announcement yet.

SwitchWithIt lost data

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SwitchWithIt lost data

    I recently started with SwitchWithIt and entered data in Locations. When I went back to the program the next day the data was gone. Any know why this happened? Thanks.

  • #2
    I am trying to help Rick with this problem by email. However, I am at a loss as to why he is having this problem. I have given him step-by-step instructions that I also followed. On my computer it works correctly. On his computer, it does not.

    Here is the procedure I gave him:

    1. On the Miscellaneous Tab select the Reporting Marks combo box located in the top left of the window.

    2. Enter a railroad Reporting Mark such as SP or CO.

    3. Select the Add button next to the Reporting Marks combo box.

    4. The combo box should clear.

    5. Select the Reporting Marks combo box down arrow to open the list of Reporting Marks.

    6. Is the reporting mark you just added shown?

    7. If it is, go down to the Default Items area (Bottom Left of the Window).

    8. Select the down arrow to open the combo box next to Home Road ID.

    9. The Reporting Marks you entered above should be displayed.

    10. Select the reporting marks by clicking on it.

    11. Make sure you enter a layout name in the edit box above the Home Road ID.

    12, Select the Save button.

    He told me that steps 1 through 5 work but when he goes to step 9 there is nothing to select. I am at a loss as to how to proceed. Any suggestions?

    David

    Comment


    • #3
      SwitchWithIt Ver 1.7.6.1 had made some changes to correct problems. Don't know what version he has, but downloading the new/latest version may be a good starting point for Rick. As you know it is tough David to help someone with problems, when you aren't there in front of the issues to see it for yourself.


      Louis
      Pacific Northwest Logging in the East Coast

      Comment


      • #4
        I found a couple of small problems when trying to troubleshoot his issues. I fixed those and posted the new version yesterday. However, after he installed the new version it didn't solve his file save issue.

        In doing some research, it appear that files not saving is a Windows 10 issue (I am hoping!!!). I found a possible fix on the Microsoft Help page. Rick has not let me know if the Microsoft fix solves the problem or not. I will post here if it does.

        David

        Comment


        • #5
          The problem turns out to be that Windows 10 would not allow the program to write to the disk without Administrator privileges. To solve the problem Rick had to right click on the program icon and select Run as Administrator. I gave him direction on how to permanently do this.

          I guess I will have to put in the program a pop-up notice if files are stuck while trying to save. This pop up will provide instructions on how to set up the program to run as administrator.

          David

          Comment


          • #6
            David, there are a whole lot of incompatible changes between Windows XP/Vista and Windows 7/8/10 regarding write access to the ProgramFiles hierarchy. I'm 5 years out of date on it, but M$s goal was keeping viruses & malware from corrupting installed programs. There are a bunch of ways to bypass this by changing security settings, but the long-term solution is to follow M$ plan and use the per-user storage they provide. Of course, this makes it more difficult to share files between different users/logins on a single machine... Sorry, I can't provide any current links but search and maybe StackOverflow should get M$s recommendations.
            James

            Comment


            • #7
              I was very glad to have this issue resolved. Certainly, I would hope that this would help others. Now, I'm looking forward to getting the information installed in the program and see just what can be done and how it works. I'd like to thank David for his patience and his willingness to work with me on this.

              Comment

              Working...
              X