Railroad Line Forums - fixing Diamond Scale Turntable
Railroad Line Forums
Username:
Password:
Save Password


Register
Forgot Password?
  Home   Forums   Events Calendar   Sponsors   Support the RRLine   Guestbook   FAQ     Register
Active Topics | Active Polls | Resources | Members | Online Users | Live Chat | Avatar Legend | Search | Statistics
Photo Album | File Lister | File Library
[ Active Members: 1 | Anonymous Members: 0 | Guests: 258 ]  [ Total: 259 ]  [ Newest Member: SandersReview ]
 All Forums
 Model Railroad Forums
 Model Railroad Construction
 fixing Diamond Scale Turntable
 New Topic |   New Poll New Poll |   Reply to Topic | 
Author Previous Topic: Starting a Layout (3rd and final time) Questions Topic Next Topic: treefoliage made out of gardenpond/aquariumfibers  

railandsail
Engine Wiper



Posted - 02/26/2020 :  4:57:08 PM  Show Profile  Reply with Quote
I have a 134 foot Diamond Scale turntable I purchased a number of years ago from an estate sale being sold off at the Timonium train show. It was all in a big box and upon cursory inspection everything looked in good order. I left it in that original box for a number of years until it be brought out for installation on my new layout.

Yesterday I unpacked it to get ready to mount it into its place on my new layout. I've discovered that the composite board onto which the pit is attached appears to have some warpage, and a few small cracks in the in the pitwall sides. I looked up the description of this piece and found this, "Factory-cast pit; pit walls with ring rail ties are Hydrocal, directly cast onto a composition wood base".

It appears as though this composite wood base got damp somewhere along the line, resulting in this warpage.

Where might I find suggestions as to how I might best remedy this situation?,...reinforce that composition board such that the pit is 'fair' and level, or somehow replace that composite base with 3/4 top grade plywood?? I'm not sure how I could 'detach' that hydrocal pit from the original composite board??

I can take some photos. Has anyone else run into such a problem??
Brian

Country: | Posts: 166

BigSteam
New Hire



Posted - 02/26/2020 :  8:16:43 PM  Show Profile  Reply with Quote
Greetings Brian,

Boy that is tuff - I have the exact same turntable - I even had it installed and working on a previously started layout - worked great, but was a bit loud - smooth though. Ran some trains across it and everything. Wish I could give you some hints on fixing, but not really sure. Pictures may help - is the inside of the pit warped or damaged where the ring rail goes? Was this all assembled when you bought it? There are a lot of depends here - in any event I think a lot of painstaking work will be involved. Maybe posting a few pics would be a good start. All the best. Chris



Country: USA | Posts: 33 Go to Top of Page

railandsail
Engine Wiper



Posted - 02/26/2020 :  8:32:56 PM  Show Profile  Reply with Quote
Weather is was cloudy & rainy this afternoon so my carport worktable was not a good photo spot. Photos tomorrow.

Brian

Country: | Posts: 166 Go to Top of Page
  Previous Topic: Starting a Layout (3rd and final time) Questions Topic Next Topic: treefoliage made out of gardenpond/aquariumfibers  
 New Topic |   New Poll New Poll |   Reply to Topic | 
Jump To:
Railroad Line Forums © 2000-2020 Railroad Line Co. Go To Top Of Page
Steam was generated in 0.22 seconds. Powered By: Snitz Forums 2000